summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authormidipix <writeonce@midipix.org>2015-03-15 20:46:36 -0400
committermidipix <writeonce@midipix.org>2015-03-15 20:46:36 -0400
commit607827292053aa25d0f0300add0798dd085a9131 (patch)
treee73ffbc6e610091dcc7dc9a5f0379f996d98025c /configure.ac
parent4cdf4f4f006da014238394af84268dad91f6a79d (diff)
downloadcbb-gcc-4.6.4-607827292053aa25d0f0300add0798dd085a9131.tar.bz2
cbb-gcc-4.6.4-607827292053aa25d0f0300add0798dd085a9131.tar.xz
compiler building blocks: add support for custom build variables.
feature detection: set a fallback value of 'yes' to modern assembler presence, PE dward support, libc-provided stack protector, and dynamic-loader header iteration. signed-off by Z. Gilboa; see copying.midipix (9cd0746c) for additional information.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ba6d84da4..9a29e0cc0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3479,3 +3479,21 @@ AC_CONFIG_FILES([Makefile],
extrasub_host="$extrasub_host"
extrasub_target="$extrasub_target"])
AC_OUTPUT
+
+
+# Compiler Building Blocks top-level-only variables
+sed -i -e 's#@cbb_cflags_for_stage1@#'"$cbb_cflags_for_stage1"'#g' \
+ -e 's#@cbb_cflags_for_stage2@#'"$cbb_cflags_for_stage2"'#g' \
+ -e 's#@cbb_cflags_for_stage3@#'"$cbb_cflags_for_stage3"'#g' \
+ -e 's#@cbb_cflags_for_stage4@#'"$cbb_cflags_for_stage4"'#g' \
+ -e 's#@cbb_cflags_for_stageprofile@#'"$cbb_cflags_for_stageprofile"'#g' \
+ -e 's#@cbb_cflags_for_stagefeedback@#'"$cbb_cflags_for_stagefeedback"'#g' \
+ Makefile || exit 2
+
+
+# Compiler Building Blocks variables
+sed -i -e 's#@cbb_xgcc_for_specs@#'"$cbb_xgcc_for_specs"'#g' \
+ -e 's#@cbb_ldflags_for_target@#'"$cbb_ldflags_for_target"'#g' \
+ -e 's#@cbb_sysroot_for_libgcc@#'"$cbb_sysroot_for_libgcc"'#g' \
+ -e 's#@cbb_cflags_for_bootstrap@#'"$cbb_cflags_for_bootstrap"'#g' \
+ Makefile || exit 2