summaryrefslogtreecommitdiff
path: root/libgfortran/Makefile.am
diff options
context:
space:
mode:
authormidipix <writeonce@midipix.org>2015-03-15 20:46:36 -0400
committermidipix <writeonce@midipix.org>2015-03-15 20:46:36 -0400
commit607827292053aa25d0f0300add0798dd085a9131 (patch)
treee73ffbc6e610091dcc7dc9a5f0379f996d98025c /libgfortran/Makefile.am
parent4cdf4f4f006da014238394af84268dad91f6a79d (diff)
downloadcbb-gcc-4.6.4-607827292053aa25d0f0300add0798dd085a9131.tar.bz2
cbb-gcc-4.6.4-607827292053aa25d0f0300add0798dd085a9131.tar.xz
compiler building blocks: add support for custom build variables.
feature detection: set a fallback value of 'yes' to modern assembler presence, PE dward support, libc-provided stack protector, and dynamic-loader header iteration. signed-off by Z. Gilboa; see copying.midipix (9cd0746c) for additional information.
Diffstat (limited to 'libgfortran/Makefile.am')
-rw-r--r--libgfortran/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/libgfortran/Makefile.am b/libgfortran/Makefile.am
index d1e6d4f94..69b03dcc5 100644
--- a/libgfortran/Makefile.am
+++ b/libgfortran/Makefile.am
@@ -1,6 +1,11 @@
## Process this file with automake to produce Makefile.in
+# Compiler Building Blocks variables
+cbb_xgcc_for_specs = @cbb_xgcc_for_specs@
+cbb_ldflags_for_target = @cbb_ldflags_for_target@
+
+
ACLOCAL_AMFLAGS = -I .. -I ../config
## May be used by toolexeclibdir.
@@ -31,7 +36,7 @@ version_dep =
endif
LTLDFLAGS = $(shell $(SHELL) $(top_srcdir)/../libtool-ldflags $(LDFLAGS)) \
- $(lt_host_flags)
+ $(lt_host_flags) $(cbb_ldflags_for_target)
toolexeclib_LTLIBRARIES = libgfortran.la
toolexeclib_DATA = libgfortran.spec