summaryrefslogtreecommitdiff
path: root/libgomp/Makefile.am
diff options
context:
space:
mode:
authormidipix <writeonce@midipix.org>2015-03-15 20:46:36 -0400
committermidipix <writeonce@midipix.org>2015-03-15 20:46:36 -0400
commit607827292053aa25d0f0300add0798dd085a9131 (patch)
treee73ffbc6e610091dcc7dc9a5f0379f996d98025c /libgomp/Makefile.am
parent4cdf4f4f006da014238394af84268dad91f6a79d (diff)
downloadcbb-gcc-4.6.4-607827292053aa25d0f0300add0798dd085a9131.tar.bz2
cbb-gcc-4.6.4-607827292053aa25d0f0300add0798dd085a9131.tar.xz
compiler building blocks: add support for custom build variables.
feature detection: set a fallback value of 'yes' to modern assembler presence, PE dward support, libc-provided stack protector, and dynamic-loader header iteration. signed-off by Z. Gilboa; see copying.midipix (9cd0746c) for additional information.
Diffstat (limited to 'libgomp/Makefile.am')
-rw-r--r--libgomp/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/libgomp/Makefile.am b/libgomp/Makefile.am
index c0c91678b..e02db181c 100644
--- a/libgomp/Makefile.am
+++ b/libgomp/Makefile.am
@@ -1,5 +1,11 @@
## Process this file with automake to produce Makefile.in
+
+# Compiler Building Blocks variables
+cbb_xgcc_for_specs = @cbb_xgcc_for_specs@
+cbb_ldflags_for_target = @cbb_ldflags_for_target@
+
+
ACLOCAL_AMFLAGS = -I .. -I ../config
SUBDIRS = testsuite
@@ -68,7 +74,7 @@ if USE_FORTRAN
nodist_finclude_HEADERS = omp_lib.h omp_lib.f90 omp_lib.mod omp_lib_kinds.mod
endif
-LTLDFLAGS = $(shell $(SHELL) $(top_srcdir)/../libtool-ldflags $(LDFLAGS))
+LTLDFLAGS = $(shell $(SHELL) $(top_srcdir)/../libtool-ldflags $(LDFLAGS)) $(cbb_ldflags_for_target)
LINK = $(LIBTOOL) --tag CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=link \
$(CCLD) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LTLDFLAGS) -o $@