summaryrefslogtreecommitdiff
path: root/libjava/Makefile.am
diff options
context:
space:
mode:
authormidipix <writeonce@midipix.org>2015-03-15 20:46:36 -0400
committermidipix <writeonce@midipix.org>2015-03-15 20:46:36 -0400
commit607827292053aa25d0f0300add0798dd085a9131 (patch)
treee73ffbc6e610091dcc7dc9a5f0379f996d98025c /libjava/Makefile.am
parent4cdf4f4f006da014238394af84268dad91f6a79d (diff)
downloadcbb-gcc-4.6.4-607827292053aa25d0f0300add0798dd085a9131.tar.bz2
cbb-gcc-4.6.4-607827292053aa25d0f0300add0798dd085a9131.tar.xz
compiler building blocks: add support for custom build variables.
feature detection: set a fallback value of 'yes' to modern assembler presence, PE dward support, libc-provided stack protector, and dynamic-loader header iteration. signed-off by Z. Gilboa; see copying.midipix (9cd0746c) for additional information.
Diffstat (limited to 'libjava/Makefile.am')
-rw-r--r--libjava/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/libjava/Makefile.am b/libjava/Makefile.am
index 52d099556..5f37b408a 100644
--- a/libjava/Makefile.am
+++ b/libjava/Makefile.am
@@ -1,5 +1,11 @@
## Process this file with automake to produce Makefile.in.
+
+# Compiler Building Blocks variables
+cbb_xgcc_for_specs = @cbb_xgcc_for_specs@
+cbb_ldflags_for_target = @cbb_ldflags_for_target@
+
+
AUTOMAKE_OPTIONS = foreign subdir-objects
ACLOCAL_AMFLAGS = -I . -I .. -I ../config -I libltdl
@@ -332,7 +338,7 @@ lib_gnu_awt_xlib_la_version_dep = $(version_dep)
libgcj_bc_la_version_dep = $(version_dep)
endif
-LTLDFLAGS = $(shell $(top_srcdir)/../libtool-ldflags $(LDFLAGS))
+LTLDFLAGS = $(shell $(top_srcdir)/../libtool-ldflags $(LDFLAGS)) $(cbb_ldflags_for_target)
GCJLINK = $(LIBTOOL) --tag=GCJ $(LIBTOOLFLAGS) --mode=link $(GCJ) -L$(here) \
$(JC1FLAGS) $(LTLDFLAGS) -o $@
GCJ_FOR_ECJX = @GCJ_FOR_ECJX@