summaryrefslogtreecommitdiff
path: root/libjava/classpath/Makefile.am
diff options
context:
space:
mode:
authorupstream source tree <ports@midipix.org>2015-03-15 20:14:05 -0400
committerupstream source tree <ports@midipix.org>2015-03-15 20:14:05 -0400
commit554fd8c5195424bdbcabf5de30fdc183aba391bd (patch)
tree976dc5ab7fddf506dadce60ae936f43f58787092 /libjava/classpath/Makefile.am
downloadcbb-gcc-4.6.4-554fd8c5195424bdbcabf5de30fdc183aba391bd.tar.bz2
cbb-gcc-4.6.4-554fd8c5195424bdbcabf5de30fdc183aba391bd.tar.xz
obtained gcc-4.6.4.tar.bz2 from upstream website;upstream
verified gcc-4.6.4.tar.bz2.sig; imported gcc-4.6.4 source tree from verified upstream tarball. downloading a git-generated archive based on the 'upstream' tag should provide you with a source tree that is binary identical to the one extracted from the above tarball. if you have obtained the source via the command 'git clone', however, do note that line-endings of files in your working directory might differ from line-endings of the respective files in the upstream repository.
Diffstat (limited to 'libjava/classpath/Makefile.am')
-rw-r--r--libjava/classpath/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/libjava/classpath/Makefile.am b/libjava/classpath/Makefile.am
new file mode 100644
index 000000000..454b2e960
--- /dev/null
+++ b/libjava/classpath/Makefile.am
@@ -0,0 +1,28 @@
+## Input file for automake to generate the Makefile.in used by configure
+
+# lib first, to compile .class files before native code, last examples
+## GCJ LOCAL: unconditionally build tools subdur
+SUBDIRS = lib doc external include native resource scripts tools $(EXAMPLESDIR)
+DIST_SUBDIRS = lib doc external include native resource scripts tools examples
+
+# Allow users to pass site-specific flags to autoreconf via an env var.
+## GCJ LOCAL: we need an extra -I here.
+ACLOCAL_AMFLAGS = -I m4 -I ../.. -I ../../config ${LOCAL_AUTORECONF_FLAGS}
+
+native: lib
+
+EXTRA_DIST = HACKING BUGS THANKYOU mauve-classpath LICENSE ChangeLog-2007 \
+ ChangeLog-2003 ChangeLog-2004 ChangeLog-2005 ChangeLog-2006 \
+ ChangeLog.gnujaxp.1 ChangeLog.gnujaxp.2 ChangeLog.libxmlj \
+ autogen.sh ChangeLog-2008
+
+DISTCHECK_CONFIGURE_FLAGS = --with-gjdoc --enable-gstreamer-peer \
+ --enable-xmlj --enable-qt-peer
+
+dist-hook:
+ -$(mkinstalldirs) $(distdir)/include
+ -cp -f $(top_srcdir)/include/*.in $(distdir)/include
+ -cp -f $(top_srcdir)/include/*.h $(distdir)/include
+
+ChangeLog:
+ cvs2cl.pl -b --gmt --log-opts "-d'1998-06-30< now'" --window 7200 --usermap ChangeLog.usermap --ignore ChangeLog --fsf