summaryrefslogtreecommitdiff
path: root/libjava/classpath/doc/api/Makefile.am
diff options
context:
space:
mode:
authorupstream source tree <ports@midipix.org>2015-03-15 20:14:05 -0400
committerupstream source tree <ports@midipix.org>2015-03-15 20:14:05 -0400
commit554fd8c5195424bdbcabf5de30fdc183aba391bd (patch)
tree976dc5ab7fddf506dadce60ae936f43f58787092 /libjava/classpath/doc/api/Makefile.am
downloadcbb-gcc-4.6.4-554fd8c5195424bdbcabf5de30fdc183aba391bd.tar.bz2
cbb-gcc-4.6.4-554fd8c5195424bdbcabf5de30fdc183aba391bd.tar.xz
obtained gcc-4.6.4.tar.bz2 from upstream website;upstream
verified gcc-4.6.4.tar.bz2.sig; imported gcc-4.6.4 source tree from verified upstream tarball. downloading a git-generated archive based on the 'upstream' tag should provide you with a source tree that is binary identical to the one extracted from the above tarball. if you have obtained the source via the command 'git clone', however, do note that line-endings of files in your working directory might differ from line-endings of the respective files in the upstream repository.
Diffstat (limited to 'libjava/classpath/doc/api/Makefile.am')
-rw-r--r--libjava/classpath/doc/api/Makefile.am55
1 files changed, 55 insertions, 0 deletions
diff --git a/libjava/classpath/doc/api/Makefile.am b/libjava/classpath/doc/api/Makefile.am
new file mode 100644
index 000000000..76b35c5f8
--- /dev/null
+++ b/libjava/classpath/doc/api/Makefile.am
@@ -0,0 +1,55 @@
+if CREATE_API_DOCS
+noinst_DATA = html
+endif
+
+sourcepath = $(top_builddir):$(top_srcdir):$(top_srcdir)/vm/reference:$(top_srcdir)/external/w3c_dom:$(top_srcdir)/external/sax:$(top_srcdir)/external/jsr166
+
+classpathbox = "<span class='logo'><a href='http://www.gnu.org/software/classpath' target='_top'>GNU Classpath</a> ($(VERSION))"
+
+if CREATE_API_DOCS
+install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/api
+ @list='$(htmllist)'; for p in $$list; do \
+ f="`echo $$p | sed -e 's|^.*/||'`"; \
+ if test -f "$$p"; then \
+ echo " $(INSTALL_DATA) $$p $(DESTDIR)$(pkgdatadir)/api/$$f"; \
+ $(INSTALL_DATA) $$p $(DESTDIR)$(pkgdatadir)/api/$$f; \
+ elif test -d "$$p"; then \
+ $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/api/$$f; \
+ fi; \
+ done
+
+uninstall-local:
+ @list='$(htmllist)'; for p in $$list; do \
+ f="`echo $$p | sed -e 's|^.*/||'`"; \
+ if test -f "$$p"; then \
+ echo " rm -f $(DESTDIR)$(pkgdatadir)/api/$$f"; \
+ rm -f $(DESTDIR)$(pkgdatadir)/api/$$f; \
+ fi; \
+ done
+endif
+
+html: create_html
+
+clean-local:
+ -rm -rf html create_html gjdoc_rawcomment.cache
+
+create_html:
+ -$(MKDIR) html > /dev/null 2>&1
+if CREATE_API_DOCS
+ $(GJDOC) \
+ -use \
+ -sourcepath "$(sourcepath)" \
+ -encoding UTF-8 \
+ -breakiterator \
+ -licensetext \
+ -linksource \
+ -splitindex \
+ -validhtml \
+ -d html \
+ -doctitle "GNU Classpath $(VERSION)" \
+ -windowtitle "GNU Classpath $(VERSION) Documentation" \
+ -header $(classpathbox) -footer $(classpathbox) \
+ -subpackages java:javax:org
+ touch create_html
+endif