summaryrefslogtreecommitdiff
path: root/libjava/classpath/native/jni/Makefile.am
diff options
context:
space:
mode:
authorupstream source tree <ports@midipix.org>2015-03-15 20:14:05 -0400
committerupstream source tree <ports@midipix.org>2015-03-15 20:14:05 -0400
commit554fd8c5195424bdbcabf5de30fdc183aba391bd (patch)
tree976dc5ab7fddf506dadce60ae936f43f58787092 /libjava/classpath/native/jni/Makefile.am
downloadcbb-gcc-4.6.4-554fd8c5195424bdbcabf5de30fdc183aba391bd.tar.bz2
cbb-gcc-4.6.4-554fd8c5195424bdbcabf5de30fdc183aba391bd.tar.xz
obtained gcc-4.6.4.tar.bz2 from upstream website;upstream
verified gcc-4.6.4.tar.bz2.sig; imported gcc-4.6.4 source tree from verified upstream tarball. downloading a git-generated archive based on the 'upstream' tag should provide you with a source tree that is binary identical to the one extracted from the above tarball. if you have obtained the source via the command 'git clone', however, do note that line-endings of files in your working directory might differ from line-endings of the respective files in the upstream repository.
Diffstat (limited to 'libjava/classpath/native/jni/Makefile.am')
-rw-r--r--libjava/classpath/native/jni/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/libjava/classpath/native/jni/Makefile.am b/libjava/classpath/native/jni/Makefile.am
new file mode 100644
index 000000000..e8db33214
--- /dev/null
+++ b/libjava/classpath/native/jni/Makefile.am
@@ -0,0 +1,47 @@
+## Input file for automake to generate the Makefile.in used by configure
+
+if CREATE_CORE_JNI_LIBRARIES
+ JNIDIRS = native-lib java-io java-lang java-net java-nio java-util
+endif
+
+if CREATE_ALSA_LIBRARIES
+ ALSADIR = midi-alsa
+endif
+
+if CREATE_DSSI_LIBRARIES
+ DSSIDIR = midi-dssi
+endif
+
+if CREATE_GTK_PEER_LIBRARIES
+ GTKDIR = gtk-peer
+endif
+
+if CREATE_QT_PEER_LIBRARIES
+ CLASSPATH_QT_PEER_DIR = qt-peer
+endif
+
+if CREATE_GCONF_PEER_LIBRARIES
+ CLASSPATH_GCONF_PEER_DIR = gconf-peer
+endif
+
+if CREATE_GSTREAMER_PEER_LIBRARIES
+ CLASSPATH_GSTREAMER_PEER_DIR = gstreamer-peer
+endif
+
+if CREATE_XMLJ_LIBRARY
+ XMLJDIR = xmlj
+endif
+
+if CREATE_GMPBI_LIBRARY
+ GMPDIR = java-math
+endif
+
+SUBDIRS = classpath $(JNIDIRS) \
+ $(ALSADIR) $(DSSIDIR) $(GTKDIR) $(CLASSPATH_QT_PEER_DIR) $(XMLJDIR) \
+ $(CLASSPATH_GCONF_PEER_DIR) $(CLASSPATH_GSTREAMER_PEER_DIR) $(GMPDIR)
+DIST_SUBDIRS = classpath java-io java-lang java-math java-net java-nio java-util \
+ gtk-peer gconf-peer gstreamer-peer qt-peer xmlj midi-alsa \
+ midi-dssi native-lib
+
+all-local:
+ $(SHELL) $(top_builddir)/scripts/check_jni_methods.sh