summaryrefslogtreecommitdiff
path: root/libjava/include/Makefile.am
diff options
context:
space:
mode:
authorupstream source tree <ports@midipix.org>2015-03-15 20:14:05 -0400
committerupstream source tree <ports@midipix.org>2015-03-15 20:14:05 -0400
commit554fd8c5195424bdbcabf5de30fdc183aba391bd (patch)
tree976dc5ab7fddf506dadce60ae936f43f58787092 /libjava/include/Makefile.am
downloadcbb-gcc-4.6.4-554fd8c5195424bdbcabf5de30fdc183aba391bd.tar.bz2
cbb-gcc-4.6.4-554fd8c5195424bdbcabf5de30fdc183aba391bd.tar.xz
obtained gcc-4.6.4.tar.bz2 from upstream website;upstream
verified gcc-4.6.4.tar.bz2.sig; imported gcc-4.6.4 source tree from verified upstream tarball. downloading a git-generated archive based on the 'upstream' tag should provide you with a source tree that is binary identical to the one extracted from the above tarball. if you have obtained the source via the command 'git clone', however, do note that line-endings of files in your working directory might differ from line-endings of the respective files in the upstream repository.
Diffstat (limited to 'libjava/include/Makefile.am')
-rw-r--r--libjava/include/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/libjava/include/Makefile.am b/libjava/include/Makefile.am
new file mode 100644
index 000000000..696a516e7
--- /dev/null
+++ b/libjava/include/Makefile.am
@@ -0,0 +1,15 @@
+## Process this file with automake to produce Makefile.in.
+
+AUTOMAKE_OPTIONS = foreign
+
+# May be used by various substitution variables.
+gcc_version := $(shell cat $(top_srcdir)/../gcc/BASE-VER)
+
+# autoconf2.13's target_alias
+target_noncanonical = @target_noncanonical@
+
+tool_include_dir = $(libdir)/gcc/$(target_noncanonical)/$(gcc_version)/include
+## The 'jni.h' here is fairly hacky, but it is simpler than trying to
+## tell Classpath about our peculiar install directory.
+tool_include__HEADERS = jni_md.h ../classpath/include/jawt.h \
+ ../classpath/include/jawt_md.h jvmpi.h ../classpath/include/jni.h