summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormidipix <writeonce@midipix.org>2015-05-30 13:36:43 -0400
committermidipix <writeonce@midipix.org>2015-05-30 13:36:43 -0400
commit095a47c7d82e9745cd864f8fb2014c10e35f3e4e (patch)
treeef463db2ea566f3333775d9db0c5706a4f6aeac5
parente100345bb651fa50ae663fdc1514e50053d45dd5 (diff)
downloadchainport-095a47c7d82e9745cd864f8fb2014c10e35f3e4e.tar.bz2
chainport-095a47c7d82e9745cd864f8fb2014c10e35f3e4e.tar.xz
coreutils-8.23: initial patch.
signed-off by Z. Gilboa; see copying.midipix (9cd0746c) for additional information.
-rw-r--r--coreutils-8.23.midipix.patch70
1 files changed, 70 insertions, 0 deletions
diff --git a/coreutils-8.23.midipix.patch b/coreutils-8.23.midipix.patch
new file mode 100644
index 0000000..bbe3170
--- /dev/null
+++ b/coreutils-8.23.midipix.patch
@@ -0,0 +1,70 @@
+diff -ru a/build-aux/config.sub coreutils-8.23/build-aux/config.sub
+--- a/build-aux/config.sub 2014-06-25 04:43:35.000000000 -0400
++++ coreutils-8.23/build-aux/config.sub 2015-05-29 00:05:01.499527002 -0400
+@@ -795,6 +795,9 @@
+ microblaze*)
+ basic_machine=microblaze-xilinx
+ ;;
++ midipix)
++ os=-midipix
++ ;;
+ mingw64)
+ basic_machine=x86_64-pc
+ os=-mingw64
+@@ -1371,7 +1374,7 @@
+ | -udi* | -eabi* | -lites* | -ieee* | -go32* | -aux* \
+ | -chorusos* | -chorusrdb* | -cegcc* \
+ | -cygwin* | -msys* | -pe* | -psos* | -moss* | -proelf* | -rtems* \
+- | -mingw32* | -mingw64* | -linux-gnu* | -linux-android* \
++ | -midipix* | -mingw32* | -mingw64* | -linux-gnu* | -linux-android* \
+ | -linux-newlib* | -linux-musl* | -linux-uclibc* \
+ | -uxpv* | -beos* | -mpeix* | -udk* \
+ | -interix* | -uwin* | -mks* | -rhapsody* | -darwin* | -opened* \
+diff -ru a/configure coreutils-8.23/configure
+--- a/configure 2014-07-18 18:07:39.000000000 -0400
++++ coreutils-8.23/configure 2015-05-29 13:09:12.583782762 -0400
+@@ -66789,3 +66789,9 @@
+ $as_echo "$as_me: WARNING: unrecognized options: $ac_unrecognized_opts" >&2;}
+ fi
+
++# bypass dependency on help2man
++if [ x"$cross_compiling" = xyes ]; then
++ mkdir -p man;
++ for f in $srcdir/src/*.c; do src=$(basename $f); doc="${src%.*}"; echo $doc; touch man/$doc.1; done
++ for f in dir sha1sum sha224sum sha256sum sha384sum sha512sum vdir; do touch man/$f.1; done
++fi
+diff -ru a/Makefile.in coreutils-8.23/Makefile.in
+--- a/Makefile.in 2014-07-18 18:22:24.000000000 -0400
++++ coreutils-8.23/Makefile.in 2015-05-29 00:07:07.787529783 -0400
+@@ -14061,6 +14061,10 @@
+ # Include the generated man dependencies.
+ @AMDEP_TRUE@@am__include@ man/dynamic-deps.mk
+
++ifeq ($(CROSS_COMPILE),yes)
++.x.1:
++
++else
+ .x.1:
+ $(AM_V_GEN)name=`echo $@ | sed 's|.*/||; s|\.1$$||'` || exit 1; \
+ case $$name in \
+@@ -14086,6 +14090,8 @@
+ && chmod a-w $@-t \
+ && mv $@-t $@
+ .PHONY: check-root
++endif
++
+ check-root:
+ $(MAKE) check TESTS='$(root_tests)' SUBDIRS=.
+
+diff -ru a/src/fs.h coreutils-8.23/src/fs.h
+--- a/src/fs.h 2014-07-18 14:33:26.000000000 -0400
++++ coreutils-8.23/src/fs.h 2015-05-29 00:05:46.219527986 -0400
+@@ -2,7 +2,7 @@
+ Please send additions to bug-coreutils@gnu.org and meskes@debian.org.
+ This file is generated automatically from ./src/stat.c. */
+
+-#if defined __linux__
++#if defined __linux__ || defined __MIDIPIX
+ # define S_MAGIC_ADFS 0xADF5
+ # define S_MAGIC_AFFS 0xADFF
+ # define S_MAGIC_AFS 0x5346414F