summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormidipix <writeonce@midipix.org>2019-09-01 14:38:36 +0000
committermidipix <writeonce@midipix.org>2019-09-01 14:41:21 +0000
commit72af7dd1258265761218c0ad412a7a1c63572fcd (patch)
tree10e562ffdf79996bf6f2610ea31fe8f161d4aedb
parentf297a9102e21374ace7040b8b7296edf26993991 (diff)
downloadchainport-72af7dd1258265761218c0ad412a7a1c63572fcd.tar.bz2
chainport-72af7dd1258265761218c0ad412a7a1c63572fcd.tar.xz
gdb-7.12: always use the bundled opcodes library.
-rw-r--r--patches/gdb-7.12.midipix.patch15
1 files changed, 0 insertions, 15 deletions
diff --git a/patches/gdb-7.12.midipix.patch b/patches/gdb-7.12.midipix.patch
index be548e5..fdfc611 100644
--- a/patches/gdb-7.12.midipix.patch
+++ b/patches/gdb-7.12.midipix.patch
@@ -58,21 +58,6 @@ diff -ru a/gdb/Makefile.in b/gdb/Makefile.in
# Where is expat? This will be empty if expat was not available.
LIBEXPAT = @LIBEXPAT@
-@@ -468,12 +468,12 @@
- # disassemblers?
- OPCODES_DIR = ../opcodes
- OPCODES_SRC = $(srcdir)/$(OPCODES_DIR)
--OPCODES = $(OPCODES_DIR)/libopcodes.a
-+OPCODES = -lopcodes
- # Where are the other opcode tables which only have header file
- # versions?
- OP_INCLUDE = $(INCLUDE_DIR)/opcode
- # Some source files like to use #include "opcodes/file.h"
--OPCODES_CFLAGS = -I$(OP_INCLUDE) -I$(OPCODES_SRC)/..
-+OPCODES_CFLAGS = -I$(OP_INCLUDE) -I$(OPCODES_SRC)/.. $(SYSROOT_FLAGS)
-
- # The simulator is usually nonexistent; targets that include one
- # should set this to list all the .o or .a files to be linked in.
@@ -599,7 +599,7 @@
$(LIBEXPAT) $(LIBLZMA) $(LIBBABELTRACE) $(LIBIPT) \
$(LIBIBERTY) $(WIN32LIBS) $(LIBGNU) $(LIBICONV)