summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormidipix <writeonce@midipix.org>2019-08-31 19:48:29 +0000
committermidipix <writeonce@midipix.org>2019-08-31 19:48:29 +0000
commit762d317e54d9b01e90f4dd0166134aa67fad624e (patch)
treecf7c60785e4ed97ee5cecc4e716a76ceb7657dde
parent04cd0e5629bca219470e4b2e9b164e064048a5e7 (diff)
downloadchainport-762d317e54d9b01e90f4dd0166134aa67fad624e.tar.bz2
chainport-762d317e54d9b01e90f4dd0166134aa67fad624e.tar.xz
gdb-7.12.midipix: updated patch.
-rw-r--r--patches/gdb-7.12.midipix.patch162
1 files changed, 81 insertions, 81 deletions
diff --git a/patches/gdb-7.12.midipix.patch b/patches/gdb-7.12.midipix.patch
index 906d1c6..3bb91f4 100644
--- a/patches/gdb-7.12.midipix.patch
+++ b/patches/gdb-7.12.midipix.patch
@@ -1,6 +1,20 @@
-diff -ru --new-file a/bfd/config.bfd b/bfd/config.bfd
+diff -ru a/bfd/Makefile.in b/bfd/Makefile.in
+--- a/bfd/Makefile.in 2016-10-07 17:09:21.000000000 +0000
++++ b/bfd/Makefile.in 2019-06-04 17:07:31.702589500 +0000
+@@ -385,8 +385,8 @@
+ # This is where we get zlib from. zlibdir is -L../zlib and zlibinc is
+ # -I../zlib, unless we were configured with --with-system-zlib, in which
+ # case both are empty.
+-ZLIB = @zlibdir@ -lz
+-ZLIBINC = @zlibinc@
++ZLIB = @zlibdir@ -lz $(SYSROOT_FLAGS)
++ZLIBINC = @zlibinc@ $(SYSROOT_FLAGS)
+ AM_CFLAGS = $(WARN_CFLAGS) $(ZLIBINC)
+ AM_CPPFLAGS = -DBINDIR='"$(bindir)"'
+ @PLUGINS_TRUE@LIBDL = @lt_cv_dlopen_libs@
+diff -ru a/bfd/config.bfd b/bfd/config.bfd
--- a/bfd/config.bfd 2016-08-01 15:50:20.000000000 +0000
-+++ b/bfd/config.bfd 2019-06-03 23:32:57.633401252 +0000
++++ b/bfd/config.bfd 2019-06-04 17:07:31.686989500 +0000
@@ -729,7 +729,7 @@
targ_archs="$targ_archs bfd_arm_arch"
want64=true
@@ -19,23 +33,9 @@ diff -ru --new-file a/bfd/config.bfd b/bfd/config.bfd
targ_defvec=i386_pe_vec
targ_selvecs="i386_pe_vec i386_pei_vec i386_elf32_vec iamcu_elf32_vec"
targ_underscore=yes
-diff -ru --new-file a/bfd/Makefile.in b/bfd/Makefile.in
---- a/bfd/Makefile.in 2016-10-07 17:09:21.000000000 +0000
-+++ b/bfd/Makefile.in 2019-06-03 23:32:57.637401253 +0000
-@@ -385,8 +385,8 @@
- # This is where we get zlib from. zlibdir is -L../zlib and zlibinc is
- # -I../zlib, unless we were configured with --with-system-zlib, in which
- # case both are empty.
--ZLIB = @zlibdir@ -lz
--ZLIBINC = @zlibinc@
-+ZLIB = @zlibdir@ -lz $(SYSROOT_FLAGS)
-+ZLIBINC = @zlibinc@ $(SYSROOT_FLAGS)
- AM_CFLAGS = $(WARN_CFLAGS) $(ZLIBINC)
- AM_CPPFLAGS = -DBINDIR='"$(bindir)"'
- @PLUGINS_TRUE@LIBDL = @lt_cv_dlopen_libs@
-diff -ru --new-file a/config.guess b/config.guess
+diff -ru a/config.guess b/config.guess
--- a/config.guess 2016-08-01 15:50:20.000000000 +0000
-+++ b/config.guess 2019-06-03 23:32:57.637401253 +0000
++++ b/config.guess 2019-06-04 17:07:31.702589500 +0000
@@ -4,6 +4,9 @@
timestamp='2016-05-27'
@@ -46,9 +46,9 @@ diff -ru --new-file a/config.guess b/config.guess
# This file is free software; you can redistribute it and/or modify it
# under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 3 of the License, or
-diff -ru --new-file a/config.sub b/config.sub
+diff -ru a/config.sub b/config.sub
--- a/config.sub 2016-08-01 15:50:20.000000000 +0000
-+++ b/config.sub 2019-06-03 23:32:57.637401253 +0000
++++ b/config.sub 2019-06-04 17:07:31.702589500 +0000
@@ -1389,7 +1389,7 @@
| -udi* | -eabi* | -lites* | -ieee* | -go32* | -aux* \
| -chorusos* | -chorusrdb* | -cegcc* \
@@ -58,9 +58,58 @@ diff -ru --new-file a/config.sub b/config.sub
| -linux-newlib* | -linux-musl* | -linux-uclibc* \
| -uxpv* | -beos* | -mpeix* | -udk* | -moxiebox* \
| -interix* | -uwin* | -mks* | -rhapsody* | -darwin* | -opened* \
-diff -ru --new-file a/gdb/configure.host b/gdb/configure.host
+diff -ru a/gdb/Makefile.in b/gdb/Makefile.in
+--- a/gdb/Makefile.in 2016-10-07 17:09:21.000000000 +0000
++++ b/gdb/Makefile.in 2019-06-04 17:07:31.733789600 +0000
+@@ -150,7 +150,7 @@
+ # This is where we get zlib from. zlibdir is -L../zlib and zlibinc is
+ # -I../zlib, unless we were configured with --with-system-zlib, in which
+ # case both are empty.
+-ZLIB = @zlibdir@ -lz
++ZLIB = @zlibdir@ -lz $(SYSROOT_FLAGS)
+ ZLIBINC = @zlibinc@
+
+ # Where is the decnumber library? Typically in ../libdecnumber.
+@@ -162,9 +162,9 @@
+ # Where is the READLINE library? Typically in ../readline.
+ READLINE_DIR = ../readline
+ READLINE_SRC = $(srcdir)/$(READLINE_DIR)
+-READLINE = @READLINE@
+-READLINE_DEPS = @READLINE_DEPS@
+-READLINE_CFLAGS = @READLINE_CFLAGS@
++READLINE = -lreadline
++READLINE_DEPS =
++READLINE_CFLAGS = $(SYSROOT_FLAGS)
+
+ # Where is expat? This will be empty if expat was not available.
+ LIBEXPAT = @LIBEXPAT@
+@@ -468,12 +468,12 @@
+ # disassemblers?
+ OPCODES_DIR = ../opcodes
+ OPCODES_SRC = $(srcdir)/$(OPCODES_DIR)
+-OPCODES = $(OPCODES_DIR)/libopcodes.a
++OPCODES = -lopcodes
+ # Where are the other opcode tables which only have header file
+ # versions?
+ OP_INCLUDE = $(INCLUDE_DIR)/opcode
+ # Some source files like to use #include "opcodes/file.h"
+-OPCODES_CFLAGS = -I$(OP_INCLUDE) -I$(OPCODES_SRC)/..
++OPCODES_CFLAGS = -I$(OP_INCLUDE) -I$(OPCODES_SRC)/.. $(SYSROOT_FLAGS)
+
+ # The simulator is usually nonexistent; targets that include one
+ # should set this to list all the .o or .a files to be linked in.
+@@ -599,7 +599,7 @@
+ $(LIBEXPAT) $(LIBLZMA) $(LIBBABELTRACE) $(LIBIPT) \
+ $(LIBIBERTY) $(WIN32LIBS) $(LIBGNU) $(LIBICONV)
+ CDEPS = $(XM_CDEPS) $(NAT_CDEPS) $(SIM) $(BFD) $(READLINE_DEPS) \
+- $(OPCODES) $(INTL_DEPS) $(LIBIBERTY) $(CONFIG_DEPS) $(LIBGNU)
++ $(INTL_DEPS) $(LIBIBERTY) $(CONFIG_DEPS) $(LIBGNU)
+
+ ADD_FILES = $(XM_ADD_FILES) $(TM_ADD_FILES) $(NAT_ADD_FILES)
+ ADD_DEPS = $(XM_ADD_FILES) $(TM_ADD_FILES) $(NAT_ADD_FILES)
+diff -ru a/gdb/configure.host b/gdb/configure.host
--- a/gdb/configure.host 2016-08-01 15:50:20.000000000 +0000
-+++ b/gdb/configure.host 2019-06-03 23:32:57.637401253 +0000
++++ b/gdb/configure.host 2019-06-04 17:07:31.718189500 +0000
@@ -109,6 +109,7 @@
;;
i[34567]86-*-msdosdjgpp*) gdb_host=go32 ;;
@@ -77,9 +126,9 @@ diff -ru --new-file a/gdb/configure.host b/gdb/configure.host
x86_64-*-freebsd* | x86_64-*-kfreebsd*-gnu)
gdb_host=fbsd64 ;;
x86_64-*-netbsd* | x86_64-*-knetbsd*-gnu)
-diff -ru --new-file a/gdb/configure.tgt b/gdb/configure.tgt
+diff -ru a/gdb/configure.tgt b/gdb/configure.tgt
--- a/gdb/configure.tgt 2016-10-07 17:09:21.000000000 +0000
-+++ b/gdb/configure.tgt 2019-06-04 14:11:22.091870500 +0000
++++ b/gdb/configure.tgt 2019-06-04 17:07:31.718189500 +0000
@@ -229,6 +229,12 @@
fi
build_gdbserver=yes
@@ -115,9 +164,9 @@ diff -ru --new-file a/gdb/configure.tgt b/gdb/configure.tgt
*-*-dicos*) gdb_osabi=GDB_OSABI_DICOS ;;
*-*-symbianelf*)
gdb_osabi=GDB_OSABI_SYMBIAN ;;
-diff -ru --new-file a/gdb/defs.h b/gdb/defs.h
+diff -ru a/gdb/defs.h b/gdb/defs.h
--- a/gdb/defs.h 2016-10-07 17:09:21.000000000 +0000
-+++ b/gdb/defs.h 2019-06-03 23:32:57.637401253 +0000
++++ b/gdb/defs.h 2019-06-04 17:07:31.733789600 +0000
@@ -602,6 +602,7 @@
GDB_OSABI_NETBSD_ELF,
GDB_OSABI_OPENBSD_ELF,
@@ -126,9 +175,9 @@ diff -ru --new-file a/gdb/defs.h b/gdb/defs.h
GDB_OSABI_GO32,
GDB_OSABI_IRIX,
GDB_OSABI_HPUX_ELF,
-diff -ru --new-file a/gdb/doc/Makefile.in b/gdb/doc/Makefile.in
+diff -ru a/gdb/doc/Makefile.in b/gdb/doc/Makefile.in
--- a/gdb/doc/Makefile.in 2016-08-01 15:50:20.000000000 +0000
-+++ b/gdb/doc/Makefile.in 2019-06-03 23:32:57.637401253 +0000
++++ b/gdb/doc/Makefile.in 2019-06-04 17:07:31.733789600 +0000
@@ -74,8 +74,8 @@
# Where is the source dir for the READLINE library doc?
@@ -151,58 +200,9 @@ diff -ru --new-file a/gdb/doc/Makefile.in b/gdb/doc/Makefile.in
+endif
uninstall: uninstall-info uninstall-man
-diff -ru --new-file a/gdb/Makefile.in b/gdb/Makefile.in
---- a/gdb/Makefile.in 2016-10-07 17:09:21.000000000 +0000
-+++ b/gdb/Makefile.in 2019-06-03 23:32:57.637401253 +0000
-@@ -150,7 +150,7 @@
- # This is where we get zlib from. zlibdir is -L../zlib and zlibinc is
- # -I../zlib, unless we were configured with --with-system-zlib, in which
- # case both are empty.
--ZLIB = @zlibdir@ -lz
-+ZLIB = @zlibdir@ -lz $(SYSROOT_FLAGS)
- ZLIBINC = @zlibinc@
-
- # Where is the decnumber library? Typically in ../libdecnumber.
-@@ -162,9 +162,9 @@
- # Where is the READLINE library? Typically in ../readline.
- READLINE_DIR = ../readline
- READLINE_SRC = $(srcdir)/$(READLINE_DIR)
--READLINE = @READLINE@
--READLINE_DEPS = @READLINE_DEPS@
--READLINE_CFLAGS = @READLINE_CFLAGS@
-+READLINE = -lreadline
-+READLINE_DEPS =
-+READLINE_CFLAGS = $(SYSROOT_FLAGS)
-
- # Where is expat? This will be empty if expat was not available.
- LIBEXPAT = @LIBEXPAT@
-@@ -468,12 +468,12 @@
- # disassemblers?
- OPCODES_DIR = ../opcodes
- OPCODES_SRC = $(srcdir)/$(OPCODES_DIR)
--OPCODES = $(OPCODES_DIR)/libopcodes.a
-+OPCODES = -lopcodes
- # Where are the other opcode tables which only have header file
- # versions?
- OP_INCLUDE = $(INCLUDE_DIR)/opcode
- # Some source files like to use #include "opcodes/file.h"
--OPCODES_CFLAGS = -I$(OP_INCLUDE) -I$(OPCODES_SRC)/..
-+OPCODES_CFLAGS = -I$(OP_INCLUDE) -I$(OPCODES_SRC)/.. $(SYSROOT_FLAGS)
-
- # The simulator is usually nonexistent; targets that include one
- # should set this to list all the .o or .a files to be linked in.
-@@ -599,7 +599,7 @@
- $(LIBEXPAT) $(LIBLZMA) $(LIBBABELTRACE) $(LIBIPT) \
- $(LIBIBERTY) $(WIN32LIBS) $(LIBGNU) $(LIBICONV)
- CDEPS = $(XM_CDEPS) $(NAT_CDEPS) $(SIM) $(BFD) $(READLINE_DEPS) \
-- $(OPCODES) $(INTL_DEPS) $(LIBIBERTY) $(CONFIG_DEPS) $(LIBGNU)
-+ $(INTL_DEPS) $(LIBIBERTY) $(CONFIG_DEPS) $(LIBGNU)
-
- ADD_FILES = $(XM_ADD_FILES) $(TM_ADD_FILES) $(NAT_ADD_FILES)
- ADD_DEPS = $(XM_ADD_FILES) $(TM_ADD_FILES) $(NAT_ADD_FILES)
-diff -ru --new-file a/gdb/osabi.c b/gdb/osabi.c
+diff -ru a/gdb/osabi.c b/gdb/osabi.c
--- a/gdb/osabi.c 2016-08-01 15:50:20.000000000 +0000
-+++ b/gdb/osabi.c 2019-06-04 00:54:53.410635600 +0000
++++ b/gdb/osabi.c 2019-06-04 17:07:31.749389600 +0000
@@ -70,6 +70,7 @@
{ "NetBSD/ELF", NULL },
{ "OpenBSD/ELF", NULL },
@@ -211,9 +211,9 @@ diff -ru --new-file a/gdb/osabi.c b/gdb/osabi.c
{ "DJGPP", NULL },
{ "Irix", NULL },
{ "HP-UX/ELF", NULL },
-diff -ru --new-file a/gdb/stub-termcap.c b/gdb/stub-termcap.c
+diff -ru a/gdb/stub-termcap.c b/gdb/stub-termcap.c
--- a/gdb/stub-termcap.c 2016-10-07 17:09:21.000000000 +0000
-+++ b/gdb/stub-termcap.c 2019-06-03 23:32:57.637401253 +0000
++++ b/gdb/stub-termcap.c 2019-06-04 17:07:31.749389600 +0000
@@ -50,11 +50,13 @@
weak (later versions, e.g., 4.8, do support it). Given this stub
file originally was Windows only, and we only needed this when we